+4 votes
1.3k views
in Bug Report by (450 points)
The individual bugs are covered in other questions already, however individually they may look like not breaking (some are even downvoted), but I'm hitting all those bugs in a combination which doesn't allow me to play the game.

My setup is two monitors, primary monitor on left 125% DPI, secondary monitor on the right with 100% DPI. My taskbar is docked to the left of the screen (I prever having more vertical screenspace when working windowed).

- at first startup the game behaved "correctly" by doing borderless window on first screen. Unfortunately after going to settings and adjusting visual quality (I don't want everything on Ultra) upon hitting apply the window is now respecting the taskbar instead of being borderless fullscreen

- the taskbar on the left, together with a monitor sized game window, causes the game to shift a good deal into the second monitor

- turning on fullscreen choses the "wrong" screen resolution, Windows starts complaining, the visual cursor is offset from the actual cursor position, I cannot click anything. I assume this is because the primary monitor is 125% DPI and the game can't deal with that.

- the game doesn't remember between restarts that I turned down visual settings to non-Ultra

- my resolution dropdown is empty, I don't have any choices (regardless of wether I'm fullscreen or not)

Currently this means the game is unplayable for me because I cannot get a working game window onto a single monitor.
closed
by (280 points)
When in wndowed i also have the taskbbar problem. (Even without a seond screen.)

Plus when tabbing out of a fulscreen session the image goes black.
(Tabbing a view times while swtching on and of the game helps.)

PS: Since i have this problem with several games it might be related to code outside the game itself. (e.g. Engine)

2 Answers

0 votes
by (460 points)
selected by
 
Best answer
From my understanding of your question, I guess that the window is now in windowed?

Have you tried hitting Alt + Enter. For me, this makes the game fullscreen.

This may help as a short term workaround as I need to do it every time I load up the game. I am unsure on why the game is forgetting your settings, however.
by (450 points)
Thanks for the suggestion, alt+enter got me out of the broken fullscreen not handling my DPI and into windowed mode (pressing it again just goes back to fullscreen, not to the borderless window of the initial start)

Settings saving now works and I can now actually select a resolution from the dropdown - not sure what happened during the initial few starts but whatever it was seems to have fixed itself.

Fullscreen still does not work and the suggestion in other threads of chosing a window resolution matching the monitor size cannot deal with my taskbar on the left side. The game window still gets pushed into the second monitor.

However since I now got out of that broken DPI fullscreen mode I can at least play in windowed mode for now ...
by (380 points)
by changing to fullscreen the game tries to set resolution to 1600x900, thats what makes the DPI go crazy cause its set to (for example) 1080. after forcing out of full screen (alt+enter) you can change ressolution of full screen wich should fix the dpi crazyness AND safe the settings for the next use.
by (100 points)
why not using borderless window mode ?
in your "GameUserSettings" just set "FullscreenMode" and "LastConfirmedFullscreenMode" to 1
[ref:https://api.unrealengine.com/INT/API/Runtime/Engine/GameFramework/UGameUserSettings/index.html]
0 votes
by (380 points)
have you tried to:

change the resolution -> aply = (broken DPI) -> alt+F = (windowed 1600x900) -> change resolution (to 1080p for example) -> aply = (Windowed 1080p) -> alt+Enter = (fullscreen 1080p) -> aply

following this fixed the problem for me. now it starts in fullscreen at 1080p (on main Desktop)

try to disable "read-only" on config file, if it doesnt get saved

located at: SYSTEM_DRIVE:\Users\USERNAME\AppData\Local\FactoryGame\Saved\Config\WindowsNoEditor\GameUserSettings.cfg

make sure you enabled "show hidden folder" to find appdata or write "%localappdata%" (including"%") in the path or "run-prompt" (Win+R)
Welcome to Satisfactory Q&A, where you can ask questions and receive answers from other members of the community.
In order to keep this site accessible for everybody, please write your post in english :)
August 28th update: We've removed downvotes! One major reason is because we don't want to discourage folks from posting legitimate suggestions / reports / questions with fear of being mass downvoted (which has been happening a LOT). So we now allow you to upvote what you like, or ignore what you don't. Points have also been adjusted to account for this change.
Please use the search function before posting a new question and upvote existing ones to bring more attention to them, It will help us a lot. <3
Remember to mark resolved questions as answered by clicking on the check mark located under the upvotes of each answer.
...