+3 votes
212 views
in Bug Report by (160 points)
edited by
I can play for 10-30 minutes and then I lose my keyboard and mouse requiring the PC to be hard reset. I've updated all drivers/bios, pulled off Logitech software and used native HID drivers and refreshed Windows. Same issue.

AMD Ryzen 7 1700, ASUS AB350 ITX, Nvidia 1070TI, Logitech G502 mouse and G610 keyboard.

I'd really love some help as I've been looking forward to Satisfactory for a while.

[Edit: I’ve tested and this only happens in Satisfactory. All other apps and games are stable.]

1 Answer

0 votes
by (5.1k points)
Since these are USB devices, have you tried different USB ports? It's highly unlikely the game is doing that. Sounds like a hardware issue.
by (160 points)
I have tried shifting ports.  I forgot to mention in my first post this only happens in Satisfactory. All other games I’ve tested (Warframe, World of Warships, Witcher 3, Factorio) are stable. All productivity apps fine.  It’s only happening in Satisfactory.
by (5.1k points)
You might try Discord - maybe a Dev can help.
Welcome to Satisfactory Q&A, where you can ask questions and receive answers from other members of the community.
In order to keep this site accessible for everybody, please write your post in english :)
August 28th update: We've removed downvotes! One major reason is because we don't want to discourage folks from posting legitimate suggestions / reports / questions with fear of being mass downvoted (which has been happening a LOT). So we now allow you to upvote what you like, or ignore what you don't. Points have also been adjusted to account for this change.
Please use the search function before posting a new question and upvote existing ones to bring more attention to them, It will help us a lot. <3
Remember to mark resolved questions as answered by clicking on the check mark located under the upvotes of each answer.
...